// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\s*[0-9 |]*\s*#[ \t]*include\s*[<"](\S+)[">]"#).unwrap();
let string = "... fatal error: Foobar.h: No such file or directory
#include <Foobar.h>
test.c:2:10: fatal error: 'file.h' file not found
2 | #include <file.h>
| ^~~~~~~~
1 error generated.
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
test.c:3:4: error: expected identifier or '('
3 | an \"unrelated\" error
| ^
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}