$re = '/^[12].*/m';
$str = '1 This is a test
2 This is a test
3 This is a test
4 This is a test
1 This is another test
2 This is another test
3 This is another test
4 This is another test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);