re = /^[12].*/m
str = '1 This is a test
2 This is a test
3 This is a test
4 This is a test
1 This is another test
2 This is another test
3 This is another test
4 This is another test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end