import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?:(async)\\s+)?function\\s+(?:([_$a-zA-Z][_$a-zA-Z0-9]*)\\s*?)?\\(((?:\\s*(?:[_$a-zA-Z][_$a-zA-Z0-9]*)\\s*)(?:,\\s*(?:[_$a-zA-Z][_$a-zA-Z0-9]*)\\s*)*?)\\)\\s*?\\{\\s*([\\s\\S]*?)\\s*\\}\\s*";
final String string = "\n"
+ " async function (param1, param2) {\n"
+ " console.log(arguments);\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}