re = /\s*(?:(async)\s+)?function\s+(?:([_$a-zA-Z][_$a-zA-Z0-9]*)\s*?)?\(((?:\s*(?:[_$a-zA-Z][_$a-zA-Z0-9]*)\s*)(?:,\s*(?:[_$a-zA-Z][_$a-zA-Z0-9]*)\s*)*?)\)\s*?\{\s*([\s\S]*?)\s*\}\s*/
str = '
async function (param1, param2) {
console.log(arguments);
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end