$re = '/^.*\/([^-]*)-.*$/m';
$str = 'http://www.example.com/0/100013573/1585710-key-description-goes-here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);