re = /^.*\/([^-]*)-.*$/m
str = 'http://www.example.com/0/100013573/1585710-key-description-goes-here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end