import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*((?:\\b(?:[djms]rs?|flam|liq|qr|st)\\.|\\b(?:[a-z]\\.){2,}|\\.\\d[\\d.]*|\\.(?:com|net|org)\\b|[^.?!])+(?:[.?!]+|$))";
final String string = "Section 2.1. Classification of Subsatnces \n\n"
+ "Mr. and Mrs. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Dr. Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't.However, this line wont do it. Qr. Test for Website.COM and Labs.ORG looks good.Creatively not working. t and finished. 9 to start. Highly Flammable Liquid Flam. H223 Liq. H334. \n"
+ "St. Bernard Dog was present.\n"
+ "The MW of gold is 100.1. Solubility is 40mg/L.";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}