import re
regex = re.compile(r"\s*((?:\b(?:[djms]rs?|flam|liq|qr|st)\.|\b(?:[a-z]\.){2,}|\.\d[\d.]*|\.(?:com|net|org)\b|[^.?!])+(?:[.?!]+|$))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Section 2.1. Classification of Subsatnces \n\n"
"Mr. and Mrs. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Dr. Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't.However, this line wont do it. Qr. Test for Website.COM and Labs.ORG looks good.Creatively not working. t and finished. 9 to start. Highly Flammable Liquid Flam. H223 Liq. H334. \n"
"St. Bernard Dog was present.\n"
"The MW of gold is 100.1. Solubility is 40mg/L.")
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)