using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[\da-f]{6}";
string input = @"The avocado, also known as butter pear or alligator pear, is a fruit that is widely ""acknowledged to #E5E5E5 have properties"" that reduce cholesterol levels... also #00FF00 ...";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}