// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)#[\da-f]{6}").unwrap();
let string = "The avocado, also known as butter pear or alligator pear, is a fruit that is widely \"acknowledged to #E5E5E5 have properties\" that reduce cholesterol levels... also #00FF00 ...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}