const regex = /^(.*?)blog/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)blog', '')
const str = `https://subdomain.website.com/groups/aa-var-group-members-only-two/blog/2017/10/22/blog-post-3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}