const regex = /\[cid:.*\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[cid:.*\\]', 'gm')
const str = `[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}