$re = '/\[cid:.*\]/m';
$str = '[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);