package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9a-zA-Z \\:@\/]+$`)
var str = `1
a
A
\
:
@
/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}