$re = '/^[0-9a-zA-Z \\\\:@\/]+$/m';
$str = '1
a
A
\\
:
@
/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);