package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\bI\b.*$`)
var str = `cat I
cat II
cat III
dog I
dog III
bird I`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}