$re = '/^.*\bI\b.*$/m';
$str = 'cat I
cat II
cat III
dog I
dog III
bird I';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);