$re = '/(?<=named )[A-Z][a-z]+/m';
$str = 'This is a Shotokon Macadamia mix named Cheryl. Sophisticated af.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);