re = /(?<=named )[A-Z][a-z]+/m
str = 'This is a Shotokon Macadamia mix named Cheryl. Sophisticated af.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end