$re = '/(?P<important>(?<=^STD_S_).+$|^.+(?=_S_STD$))/m';
$str = 'STD_S_important
important_S_STD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);