re = /(?P<important>(?<=^STD_S_).+$|^.+(?=_S_STD$))/m
str = 'STD_S_important
important_S_STD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end