package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z0-9-]+\.[a-z0-9]{2,}$)`)
var str = `mysite.com
test.net
testing.-com
camels.com.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}