$re = '/^([a-z0-9-]+\.[a-z0-9]{2,}$)/m';
$str = 'mysite.com
test.net
testing.-com
camels.com.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);