const regex = /\w*(\.([a-zA-Z0-9]+[-_]+)?careerfy(?![^\W_])([-_]+[a-zA-Z0-9]+)?)\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*(\\.([a-zA-Z0-9]+[-_]+)?careerfy(?![^\\W_])([-_]+[a-zA-Z0-9]+)?)\\w*', 'gm')
const str = `.crfy-careerfy { display: none}
.careerfy { font-size: 12; font-family: "arial"}
.crfy-careerfyds-add-space {background-color: red}
.crfy-careerfy_add-space {background-color: red}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}