re = /\w*(\.([a-zA-Z0-9]+[-_]+)?careerfy(?![^\W_])([-_]+[a-zA-Z0-9]+)?)\w*/m
str = '.crfy-careerfy { display: none}
.careerfy { font-size: 12; font-family: "arial"}
.crfy-careerfyds-add-space {background-color: red}
.crfy-careerfy_add-space {background-color: red}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end