import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?(?:\\.[0-9]+|[0-9]+(?:\\.[0-9]*)?)(?:[eE][-+]?[0-9]+)?$";
final String string = "0.0001\n"
+ "-5\n"
+ "0.3425\n"
+ "1e-4\n"
+ "1E-4\n"
+ "-4.34\n"
+ "5.\n"
+ ".5\n"
+ "-.5\n"
+ "+5\n\n\n"
+ "1Ee-4\n"
+ "Test123\n"
+ "+-2\n"
+ ".\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}