package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4})(\d{2})(\d{2})`)
var str = `19991111`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}