$re = '/(\d{4})(\d{2})(\d{2})/';
$str = '19991111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);