using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\shref=([""'])(.*?)\1";
string input = @"<ul>
<li><a href=""/page/"">pag2 </a></li><li><a href=""/page/"">pag2 </a></li><li><a href=""/page/"">pag2 </a></li>
</ul>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}