#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$(\d+)"
Local $sString = "Xbox 360 (black) Elite Console 120GB (Mason City Illinois ) $200" & @CRLF & _
"" & @CRLF & _
"$200 2013 North Trail Camper (RT 202. Manchester, Maine) $224/mo." & @CRLF & _
"" & @CRLF & _
"Snowmobile Bike trailers (Winthrop / Augusta) $40 Monthly" & @CRLF & _
"" & @CRLF & _
""Great Xmas Gift" XBox 360 Guitar Hero (Springfied) $80"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")