import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(\\d+)";
final String string = "Xbox 360 (black) Elite Console 120GB (Mason City Illinois ) $200\n\n"
+ "$200 2013 North Trail Camper (RT 202. Manchester, Maine) $224/mo.\n\n"
+ "Snowmobile Bike trailers (Winthrop / Augusta) $40 Monthly\n\n"
+ "\"Great Xmas Gift\" XBox 360 Guitar Hero (Springfied) $80";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}