#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\d*)|(\d+\.\d*)[^0\D])$"
Local $sString = "0.0.0" & @CRLF & _
"1000" & @CRLF & _
"12123" & @CRLF & _
"01212" & @CRLF & _
"10.01" & @CRLF & _
"10.0" & @CRLF & _
"10." & @CRLF & _
"64.6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")