re = /^((\d*)|(\d+\.\d*)[^0\D])$/m
str = '0.0.0
1000
12123
01212
10.01
10.0
10.
64.6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end