re = /<([^>]*)>/m
str = 'This is a <sentence> with several words <demarcated> by <brackets>.
New line. Here is a <second> sentence. Glahluahlgghladaljdlhgl<jad>gdhl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end