// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\t| )*(?:#|%|;|//|--|REM|C|!) (?:#{64} (.*)|#{32} (.*)|#{16} (.*)|#{8} (.*)|#{4} (.*)|#{2} (.*))$").unwrap();
let string = "Valid comments that start with \"#\":
# ################################################################ First Level
# ################################ Second Level
# ################ Third level
# ######## Fourth Level
# #### Fifth level
# ## Sixth level
Valid comments that start with different characters:
// ################################################################ 1st Level
; ################################ 2nd Level
REM ################ 3rd level
C ######## 4th Level
% #### 5th level
-- ## 6th level
Valid comments that start with spaces or tabs:
# ################################################################ 1st level
; ################################ 2nd Level
Invalid comments:
################################################################ No initial character
; ################################################ Hashes not a power of 2
@ ################ Character not recognized
C ########No space after hashes
% %%%%%%%% No hashes
. # #### Period before spaces
;#### No space after character";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}