import Foundation
let pattern = ##"^(?:\t| )*(?:#|%|;|//|--|REM|C|!) (?:#{64} (.*)|#{32} (.*)|#{16} (.*)|#{8} (.*)|#{4} (.*)|#{2} (.*))$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #################################################################"""
Valid comments that start with "#":
# ################################################################ First Level
# ################################ Second Level
# ################ Third level
# ######## Fourth Level
# #### Fifth level
# ## Sixth level
Valid comments that start with different characters:
// ################################################################ 1st Level
; ################################ 2nd Level
REM ################ 3rd level
C ######## 4th Level
% #### 5th level
-- ## 6th level
Valid comments that start with spaces or tabs:
# ################################################################ 1st level
; ################################ 2nd Level
Invalid comments:
################################################################ No initial character
; ################################################ Hashes not a power of 2
@ ################ Character not recognized
C ########No space after hashes
% %%%%%%%% No hashes
. # #### Period before spaces
;#### No space after character
"""#################################################################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)