using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b(?:dog|cat)s?|\G)\s+(?:((?!(?:dog|cat)s?\b)\w{3,})|\S+)(?=.*?\s+(?:dog|cat)s?\b)";
string input = @"Dogs are nice animals. Cats are not. My cat ate a mice. My dog once ate a fry. My dog once ate a fry. My cat ate a mice. The catalog of the best dogs is around here somewhere.
test string
dog cat
dog and cat
this is a dog and a cat dog
this is cat and a catdog cat cat dog dog
test dog
dog test cat test dog testcat cat";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}