import re
regex = re.compile(r"(?:\b(?:dog|cat)s?|\G)\s+(?:((?!(?:dog|cat)s?\b)\w{3,})|\S+)(?=.*?\s+(?:dog|cat)s?\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Dogs are nice animals. Cats are not. My cat ate a mice. My dog once ate a fry. My dog once ate a fry. My cat ate a mice. The catalog of the best dogs is around here somewhere. \n\n"
"test string\n\n"
"dog cat\n"
"dog and cat\n"
"this is a dog and a cat dog\n\n"
"this is cat and a catdog cat cat dog dog\n\n"
"test dog\n\n"
"dog test cat test dog testcat cat")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")