package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s*\{[^\{\}]+\}\s*)+`)
var str = `{ {spin1|spin2} {blabla1|blabla2} }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}