$re = '/(\s*\{[^\{\}]+\}\s*)+/m';
$str = '{ {spin1|spin2} {blabla1|blabla2} }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);