const regex = /^\s*[1-9][0-9]*\s*(?=([., \t]))(?:\s*(?:\1|\r?\n)\s*[1-9][0-9]*)+\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[1-9][0-9]*\\s*(?=([., \\t]))(?:\\s*(?:\\1|\\r?\\n)\\s*[1-9][0-9]*)+\\s*$', '')
const str = `10 11 12 13 14 30
9 41 42 44 46 48
10 11 12 13 14 30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}