re = /^\s*[1-9][0-9]*\s*(?=([., \t]))(?:\s*(?:\1|\r?\n)\s*[1-9][0-9]*)+\s*$/
str = '10 11 12 13 14 30
9 41 42 44 46 48
10 11 12 13 14 30'
# Print the match result
str.match(re) do |match|
puts match.to_s
end