#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s?\d+\s?,){4}\s?\d+"
Local $sString = "372591089, jni, oduction, to, A, hnr, android, -"The, mAt,352, 268, 638, 257, 65, JI, 0, 00, 0, 0, al, 31/07/2015, oHa, Jile, 786118029," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")