$re = '/\$\{([\w-]+)\}/m';
$str = 'for(var i=0;i<${My-Var}.length;i++){ alert(${My-Var}[i]); if(${FooBar}) { ${Bazz}(); } }';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;