// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$\{([\w-]+)\}").unwrap();
let string = "for(var i=0;i<${My-Var}.length;i++){ alert(${My-Var}[i]); if(${FooBar}) { ${Bazz}(); } }";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}