use strict;
my $str = '<tags>This is an example</tags>';
my $regex = qr~(?s)(?:\G(?!\A)|<tags>(?=.*?</tags>))(?:(?!</?tags>).)*?\K\s+~mp;
my $subst = ',';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";