import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'DateTime'\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}).*Target Name: (?'TargetName'\\w+\\-\\w+)\\n.*Target Type\\: (?'TargetType'\\w+)\\n.*Cycle Time: (?'CycleTime'\\d+.\\d+)";
final String string = "2018-09-03 15:01:58,384 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 24.178 seconds\n"
+ "2018-09-03 15:01:59,934 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-11\n"
+ "2018-09-03 15:01:59,934 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:02:21,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.952 seconds\n"
+ "2018-09-03 15:06:52,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-16\n"
+ "2018-09-03 15:06:52,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:07:27,960 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 35.298 seconds\n"
+ "2018-09-03 15:10:16,361 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BPRD26-1\n"
+ "2018-09-03 15:10:16,361 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: TOOL\n"
+ "2018-09-03 15:10:41,524 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 25.179 seconds\n"
+ "2018-09-03 15:14:42,750 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-1\n"
+ "2018-09-03 15:14:42,750 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:15:06,262 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 23.523 seconds\n"
+ "2018-09-03 15:17:25,399 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-6\n"
+ "2018-09-03 15:17:25,399 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:17:46,641 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.258 seconds\n"
+ "2018-09-03 15:21:22,709 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-2\n"
+ "2018-09-03 15:21:22,709 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:21:43,892 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.194 seconds\n"
+ "2018-09-03 15:26:42,393 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-7\n"
+ "2018-09-03 15:26:42,393 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n"
+ "2018-09-03 15:27:06,475 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 24.093 seconds\n"
+ "2018-09-03 15:28:29,608 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-5\n"
+ "2018-09-03 15:28:29,608 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}