package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bterm|term\b`)
var str = `a term is
the terms are
the midterm was
the midterms were`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}