$re = '/\bterm|term\b/';
$str = 'a term is
the terms are
the midterm was
the midterms were';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);